Border Gateway Protocol (BGP) Border Gateway Protocol (BGP) merupakan routing antara beda autonomous system berbeda. autonomous s...

Konfigurasi Border Gateway Protocol (BGP)

1:41 PM Galih Permana 0 Comments



 Border Gateway Protocol (BGP)

Border Gateway Protocol (BGP) merupakan routing antara beda autonomous system berbeda. autonomous system adalah sebuah kelompok jaringan yang berada dalam sistem administrasi yang sama.

Salah satu contoh pemanfaatan BGP adalah digunakan untuk pertukaran informasi Internet dan dijadikan sebagai routing utama oleh ISP (internet service provider). ...



Kantor biasanya menggunakan Interior Gateway Protocol (IGP) seperti RIP,OSPF atau eigrp untuk melakukan pertukaran informasi di jaringan mereka.

Kantor ingin berkomunikasi dengan kantor mereka di luar kota, lalu mereka kontak ke ISP. Dari sana ISP akan menggunakan routing BGP untuk menyambungkan jaringan kantor pelanggan tersebut.

Ada dua jenis routingan BGP, Ketika BGP dipakai dalam Autonomous System (AS yang berbeda), maka protokol ini disebut sebagai External BGP (EBGP). Tetapi saat ISP melakukan routing BGP dalam satu AS, maka protokol disebut sebagai Interior BGP (IBGP).







Setting IBGP Peering


Cek kondisi awal :

Kondisi routing bgp tidak aktif

R2#show ip bgp
% BGP not active



R1
interface Loopback2
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 10.10.10.1 mask 255.255.255.255
(ip yang ada di dalam R1)
 neighbor 12.12.12.2 remote-as 12
(IP next hop interface fa1/0 ke R2)
 no auto-summary
=============================
R2
terface Loopback2
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.1 mask 255.255.255.255
 neighbor 12.12.12.1 remote-as 12
(IP next hop interface fa1/0 ke R1)
 no auto-summary



Cek kondisi IBGP peering sudah up

R2#show ip bgp  summary
BGP router identifier 12.12.12.2, local AS number 12
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
12.12.12.1      4    12       4       4        1    0    0 00:00:32        0
Tulisan di atas menunjukkan kalau R2 memunyai neighbor 12.12.12.1 dengan as number 12. Dan kondisi bgp mereka up (ditandai dengan muncul angka 00:00:32, jika yang muncul inactive, maka belum terkoneksi satu sama lain bgp-nya)

Penambahan Network di BGP

R1#sh run int lo1
Building configuration...

Current configuration : 66 bytes
!
interface Loopback1
 ip address 10.10.10.1 255.255.255.255
end

Saat ditambahkan lo1 10.10.10.1 255.255.255.255 pada bagian network router bgp 12 di R1, maka muncul di R2 sebagai berikut ini

R2#show ip bgp
BGP table version is 2, local router ID is 12.12.12.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.10.10.1/32    12.12.12.1               0    100      0 i
Baca hasil routing di atas adalah, pada R2 muncul routingan 10.10.10.1 yang bisa dicapai dengan koneksi lewat ip 12.12.12.1. Routingan ini diperoleh dengan perintah network 10.10.10.1 mask 255.255.255.255 yang ditambahkan pada R1 (ditandai dengan huruf i)

Pada saat sh ip bgp summary di R1, cek paling kanan, sudah muncul prefix, berarti ada update routingan yang masuk. Ini perintah untuk cek koneksi BGP dengan router R2.

R1#sh ip bgp summary
BGP router identifier 12.12.12.1, local AS number 12
BGP table version is 3, main routing table version 3
2 network entries using 202 bytes of memory
2 path entries using 96 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 418 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
12.12.12.2      4    12      12      12        3    0    0 00:07:12        1
R1#

Saat ditambahkan ip loopback0 20.20.20.1 di R2 pada bagian network router bgp 12.

cek lagi sh ip bgp


R1#sh ip bgp
BGP table version is 3, local router ID is 12.12.12.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.1/32    0.0.0.0                  0         32768 i
*>i20.20.20.1/32    12.12.12.2               0    100      0 i


muncul angka 20.20.20.1


coba cek sh ip route maka akan muncul routingan bgp yang telah kita tambahkan

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/32 is subnetted, 1 subnets
B       20.20.20.1 [200/0] via 12.12.12.2, 00:04:07
     10.0.0.0/32 is subnetted, 1 subnets
C       10.10.10.1 is directly connected, Loopback1
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet1/0

IBGP Peering Loopback
Sekarang jika menggunakan interface loopback sebagai peering bgp. Menggunakan interface loopback lebih aman, karena jika link utama mati maka bisa masuk koneksi lewat link lain. Dan karena diarahkan ke loopback tersebut, maka bgp peering antara dua router tersebut tetap akan aktif.



Pada R1
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 10.10.10.1 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 12
(diarahkan ke loopback R2)
 neighbor 2.2.2.2 update-source Loopback2
(menggunakan loopback R1 koneksinya)

 no auto-summary
========================
Pada R2
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.1 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 12
(diarahkan ke loopback R1)
 neighbor 1.1.1.1 update-source Loopback2
(menggunakan loopback R2 koneksinya)
 no auto-summary

Seting update-source loopback pada R2 dan R1,


R2#sh ip bgp sum
BGP router identifier 20.20.20.1, local AS number 12
BGP table version is 3, main routing table version 3
2 network entries using 202 bytes of memory
2 path entries using 96 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 418 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4    12       5       5        3    0    0 00:00:02        1
R2#

maka muncul pada bgp peering adalah 1.1.1.1, seperti contoh di atas
.



BGP Peering Beda AS


Selama ini kita mainnya hanya di dalam satu AS yang sama. Dalam lingkup ISP kita saja. Nah,jika kita ingin melakukan koneksi ke jaringan yang berbeda AS(ISP yang berbeda), di bawah ini maka ada beberapa setingan yang perlu ditambahkan. Nanti kita cek di bawah ini yah...

Perintah yang dimasukkan adalah pada router R2 dan R3 (baru)
R2
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.1 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 12
 neighbor 1.1.1.1 update-source Loopback2
 neighbor 23.23.23.3 remote-as 3
(peering ke AS yang berbeda)
 no auto-summary

========================
R3
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.3 mask 255.255.255.255
 neighbor 23.23.23.2 remote-as 12
(peering ke AS yang berbeda lewat interface)
 no auto-summary

Hasilnya pada R2, dengan perintah show ip bgp

R2#show ip bgp
BGP table version is 4, local router ID is 20.20.20.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 3.3.3.3/32       23.23.23.3               0             0 3 i (dari AS 3)
*>i10.10.10.1/32    1.1.1.1                  0    100      0 i
*> 20.20.20.1/32    0.0.0.0                  0         32768 i

Terlihat routingan ip 3.3.3.3 sudah masuk ke dalam routing table R2, ditunjukkan dengan path angka AS 3. Tulisan i menunjukkan kalau ia berasal dari perintah network yang didefinisikan pada R3.


BGP Peering Beda AS (Multihop - Loopback)
Yang pertama di atas untuk berbeda AS yang menggunakan peering ip interface-nya. Sekarang coba koneksi ke jaringan beda AS tapi menggunakan ip loopback mereka.. Maka kita perlu menggunakan BGP multihop. Cara setting adalah

R2
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.1 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 12
 neighbor 1.1.1.1 update-source Loopback2
 neighbor 3.3.3.3 remote-as 3
 neighbor 3.3.3.3 ebgp-multihop 255
(peering ke AS yang berbeda lewat loopback)
 neighbor 3.3.3.3 update-source Loopback2
 no auto-summary

R3
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.3 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 12
 neighbor 2.2.2.2 ebgp-multihop 255
(peering ke AS yang berbeda lewat loopback)
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary

Lalu cek koneksi ebgp peering antara R2 dengan R3. Terlihat ebgp mereka sudah aktif.
R3#sh ip bgp summary
BGP router identifier 3.3.3.3, local AS number 3
BGP table version is 8, main routing table version 8
3 network entries using 303 bytes of memory
3 path entries using 144 bytes of memory
3 BGP path attribute entries using 180 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 651 total bytes of memory
BGP activity 5/2 prefixes, 5/2 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4    12      26      25        8    0    0 00:20:59        2
R3#

BGP Next-Hop Self


R2
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.1 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 12
 neighbor 1.1.1.1 update-source Loopback2
 neighbor 1.1.1.1 next-hop-self
 neighbor 3.3.3.3 remote-as 3
 neighbor 3.3.3.3 ebgp-multihop 255
(Peering ke loopback R3)
 neighbor 3.3.3.3 update-source Loopback2
 no auto-summary
Cek Pada R1, ternyata dia tidak mengetahui routingan dari R3,untuk itu agar bisa tampil routing table di R1 maka pada R2 ditambahkan command bgp next-hop-self yang peering ke 1.1.1.1

Setelah ditambahkan maka pada R1 muncul

R1#sh ip bgp
BGP table version is 102, local router ID is 10.10.10.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i3.3.3.3/32       2.2.2.2                  0    100      0 3 i
*> 10.10.10.1/32    0.0.0.0                  0         32768 i
*>i20.20.20.1/32    2.2.2.2                  0    100      0 i
*>i30.30.30.1/32    2.2.2.2                  0    100      0 3 i
*>i60.60.60.1/32    2.2.2.2                  0    100      0 3 i
R1#sh ip route

Coba test ping ke ip loopback R3


R1#ping 60.60.60.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 60.60.60.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/44/52 ms

R1#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/36/40 ms
R1#


Ok berarti kita sudah berhasil mendapatkan routingan dari R3 lewat BGP.

BGP Password Autentifikasi

R1
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 10.10.10.1 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 12
 neighbor 2.2.2.2 update-source Loopback2
 neighbor 2.2.2.2 password CISCO

R2
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.1 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 12
 neighbor 1.1.1.1 update-source Loopback2
 neighbor 1.1.1.1 next-hop-self
 neighbor 1.1.1.1 password CISCO
Agar peering antara R1 dan R2 dapat terjadi maka perlu dilakukan autentifikasi password.

BGP Origin


Pemahaman tentang asal routingan yang muncul pada tabel bgp. Cek hasil routingan yang muncul di bawah ini

R1#sh ip bgp
BGP table version is 6, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       0.0.0.0                  0         32768 i
*> 2.2.2.2/32       12.12.12.2               0             0 200 i
*> 3.3.3.3/32       12.12.12.2                             0 200 i
*> 30.30.30.30/32   12.12.12.2               0             0 200 ?
*> 33.33.33.33/32   12.12.12.2                             0 200 ?
R1#


I = berasal dari BGP yang dibuat dengan perintah network
? = berasal dari hasil redistribute

R1 untuk mencapai network 2.2.2.2 dan 3.3.3.3 akan masuk ke AS 200.


BGP Pindah Jalur

Kita akan coba pindah jalur dengan menggunakan MED (metric). Jika nilai metric-nya tinggi maka jalur tersebut tidak akan dipilih. R1 ingin ping ke R3, tapi tidak mau lewat jalur Fa0/0, padahal secara default akan lewat Fa0/0. Agar tidak lewat Fa0/0 maka ditambahkan metric(med) pada bgp peering antara R1 dengan R3.

R1
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 13.13.13.1 255.255.255.0
 duplex full
!
interface Serial1/0
 ip address 12.12.12.1 255.255.255.0
 serial restart_delay 0

router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 neighbor 12.12.12.2 remote-as 23
 neighbor 13.13.13.3 remote-as 23
 no auto-summary
!
ip classless

====================
R3
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
interface FastEthernet2/0
 ip address 13.13.13.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet2/1
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
!
router bgp 23
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.3 mask 255.255.255.255
 neighbor 13.13.13.1 remote-as 1
 neighbor 13.13.13.1 route-map MED out
(neighbor ke 13.13.13.1 dikasi metric 200)
 neighbor 23.23.23.2 remote-as 23
 no auto-summary
!
route-map MED permit 10
(seting metric menjadi 200)
 set metric 200

====================
R2
interface FastEthernet0/1
 ip address 23.23.23.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 12.12.12.2 255.255.255.0
 serial restart_delay 0

router bgp 23
 no synchronization
 bgp log-neighbor-changes
 network 2.2.2.2 mask 255.255.255.255
 neighbor 12.12.12.1 remote-as 1
 neighbor 23.23.23.3 remote-as 23
 no auto-summary

Setelah dilakukan seting maka hasilnya adalah

R1#traceroute
Protocol [ip]:
Target IP address: 3.3.3.3
Source address: 1.1.1.1
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 3.3.3.3
  1 12.12.12.2 56 msec 16 msec 64 msec
  2 23.23.23.3 28 msec 32 msec *
R1#
Jika tanpa ditambahkan MED maka routingan tersebut akan lewat 13.13.13.3

0 komentar:

Klik dan Dapatkan $0.5

STMIK RADIO 107.8 FM

Free Shoutcast HostingRadio Stream Hosting